1.11.09

LanguageTool 1.0.0

Dziś ukazała się najnowsza wersja korektora LanguageTool z okrągłym numerem 1.0.0!

Podstawowe zmiany:
  • obsługa języka duńskiego, katalońskiego i galisyjskiego;
  • nowe reguły i poprawki w słownikach dla języka duńskiego, francuskiego, włoskiego, polskiego, hiszpańskiego, szwedzkiego i rosyjskiego;
  • język polski ma ponad 1000 reguł;
  • poprawione różnego rodzaju usterki.

Uwaga. Ta wersja działa wyłącznie w OpenOffice.org w wersji 3.0.1 lub nowszej! Przed instalacją programu OpenOffice.org 3.0.1 należy usunąć wszystkie wcześniejsze wersje LanguageTool zainstalowane w OpenOffice.org.

Instalacja:

W programie OpenOffice.org 3.0.1 lub nowszym
  • Metoda prosta
    Dwukrotnie kliknij pobrany plik LanguageTool-1.0.0.oxt. Jeśli w systemie jest zarejestrowane rozszerzenie .oxt (robią to aktualne wersje OpenOffice.org), nastąpi uruchomienie instalatora.
  • Metoda tradycyjna
Kliknij polecenie Narzędzia > Menedżer rozszerzeń > Dodaj, a następnie wybierz plik LanguageTool-1.0.0.oxt. Zamknij pakiet (łącznie z modułem szybkiego uruchamiania).

Po ponownym otwarciu OpenOffice.org będzie możliwe automatyczne sprawdzanie tekstu. Jako test wpisz zdanie: „To zdanie zdanie jest z błędem”.

Bez programu OpenOffice.org
  • Rozpakuj archiwum LanguageTool-1.0.0.oxt (jest to plik w formacie .zip) i uruchom plik LanguageToolGui.jar, klikając go dwukrotnie. Jeśli na danym komputerze nie skonfigurowano skojarzenia dla plików *.jar, uruchom program z wiersza poleceń za pomocą polecenia java -jar LanguageToolGUI.jar. Plik LanguageTool.jar jest natomiast korektorem działającym z poziomu wiersza poleceń.
  • Rozpakuj znajdujący się w archiwum plik standalone-libs.zip do tego samego katalogu, do którego rozpakowano pliki z archiwum.

W razie problemów

  1. Należy upewnić się, czy w systemie zainstalowana jest Java w wersji co najmniej 1.5. Środowisko GIJ ma błędy uniemożliwiające użytkowanie LT; należy korzystać z Javy w wersji IcedTea lub firmy Sun. Zalecana jest Java 1.6.
  2. Ta wersja środowiska Java musi być widoczna dla OpenOffice.org (Narzędzia > Opcje > Java).
  3. Nazwa użytkownika w systemie Windows nie może zawierać polskich liter, jeśli pakiet OpenOffice.org jest starszy niż 3.1.
  4. W systemie Ubuntu konieczna jest instalacja pakietu openoffice.org-java-common, gdyż OpenOffice jest domyślnie instalowany bez bibliotek obsługujących Javę.

15 komentarzy:

Psz pisze...

Dziękujemy!

Anonimowy pisze...

Nie moge uruchopmić programu, LanguageTool.jnlp
Jawę mam zainstalowaną.
Brak polaczenia z serwerem.
Wychodzi na to, że bez połączenia z serwerem program jest bezużyteczny. Chyba że czegoś nie wiem. Dwa dni temu jeszzce działał.

Anonimowy pisze...

Czy Language Tool 1.0.0 działa z Vista 64 bit? Zainstalowałem z najnowszą wersją Open Office i wyskakują błędy Java (Java w wersji 1.6).

Marcin Miłkowski pisze...

Powinien działać, ale błędy są nie do ozdoby, proszę je przytoczyć, wtedy zobaczymy, co się dzieje :)

Marcin Miłkowski pisze...

Aha, co do JNLP, to nie jest wymagane połączenie z serwerem, jeśli pliki są pobrane do bufora Javy. Jeśli nie są, to będzie kolejne pobranie - i tu już wszystko zależy od tego, czy się uda pobrać pliki.

Anonimowy pisze...

Nie mogę zainstalować Language Tool. Za każdym razem dostaję komunikat "Could not create java implementation loader". Obojętnie czy instaluję klikając podwójnie na plik .oxt czy przez menedżera rozszerzeń. Mam Javę Sun zainstalowaną - 6 update 18. Jest widoczna i zaznaczona w Narzędzia-Opcje-Java. Właściwie nie mogę zainstalować żadnych rozszerzeń wykorzystujących Javę. Ten sam komunikat. Próbowałem chyba wszystkich rozwiązań jakie znalazłem w internecie, łącznie z usunięciem folderu "user" i nic. System to Windows XP SP3.

Marcin Miłkowski pisze...

W folderze Dane aplikacji\OpenOffice.org\user\config jest plik javasettings_Windows_x86.xml

Tam powinny być ustawienia Javy. Najważniejszy jest fragment location, np.:

file:///C:/Program%20Files/Java/jre6

Mi wielokrotnie pomagało usunięcie tego pliku w razie kłopotów. Tylko on ma wpływ na obsługę Javy.

Anonimowy pisze...

Usunięcie pliku javasettings_Windows_x86.xml
nic nie dało. Wciąż ten komunikat. Usunięcie lub edytowanie wersu "location" też nic. Java działa poprawnie na stronach internetowych. Nie ma nadziei?

Marcin Miłkowski pisze...

Hm, a która wersja OOo?

Anonimowy pisze...

OO 3.2.0, a właściwie Go-OO 3.2.0

Anonimowy pisze...

Mam w pracy na XP i mi hula, mam w domu Vista Biznes - i mi się wywala :(. Jest zduplikowany jakiś klucz.

Anonimowy pisze...

Działa i na Viście, po prostu przy dodawaniu dodatków trzeba zamknąć OpenOffice oraz quickstart - uruchomić jako administrator i dopiero instalować.

Jacek K.

Anonimowy pisze...

bardzo ciekawy program i instrukcja instalacji - mówię o languageTool 1.0.0 - problem polega na tym, że w pliku "zip" brak jest pliku od którego należy rozpocząć instalację tj LanguageTool-1.0.0.oxt
A tak poza tym to prawdopodobnie fajne narzędzie.

Marcin Miłkowski pisze...

Ciekawe, o jakim osobnym pliku .zip mowa, skoro program jest dystrybuowany w pliku z rozszerzeniem .oxt. Wystarczy ściągnąć i dwa razy kliknąć.

Anonimowy pisze...

Zauważyłem u mnie dziwną nieprawidłowość. Mianowicie kiedy tworzę nowy dokument poprzez: PPM na pulpicie/Nowy/OpenDocument Dokument tekstowy to LT nie działa prawidłowo. Po pierwsze widzę, że nie zaznacza błędów, z którymi to zwykle robi. Próbuje sprawdzić czy działa w ogóle, daję Narzędzia/LT/Konfiguracja. Wtedy otrzymuję komunikat: Error: Sory,the document language 'zxx' is not supported by LanguageTool. Natomiast tworząc OD dokument tekstowy poprzez menu start lub skrót ogólny openoffice, LT działa i żaden taki komunikat się nie pojawia. Instalowałem OO na dwóch komputerach i na obu dzieje się to samo. Konfiguracja jest podobna: Win XP i najnowsze wersje OO i LT. Na jednym była to świeża instalacja najnowszych wersji. Czy popełniłem jakiś błąd przy instalacji? Czy może być jakiś inny powód takiego błędu. Pozdrawiam. Dzięki za uwagę.